AtlasQuest 4.5.0 Beta

Interface for displaying an instance's quests.

Moderators: Lothaer, thandrenn, asurn

Locked
User avatar
thandrenn
Posts: 307
Joined: Sun Dec 10, 2006 2:10 am
Location: Pennsylvania, USA

AtlasQuest 4.5.0 Beta

Post by thandrenn » Tue Oct 12, 2010 5:27 am

If you immediately know the candlelight is fire, then the meal was cooked a long time ago.

Changes for 4.5.0 Beta
- Basic (very basic) Patch 4.0 support. This should be enough to keep the error messages away for now.
- Fixed attainment level for SM: Into The Scarlet Monastery (thanks auha)
- Localizations updated: deDE, zhTW.


Download Links
WoW Interface
Curse Gaming
WoW UI
Google Code
Image

User avatar
arith
Posts: 910
Joined: Tue Apr 04, 2006 4:42 am
Location: Kalimdor

Re: AtlasQuest 4.5.0 Beta

Post by arith » Thu Oct 14, 2010 10:29 am

It's a good news.
Well done.

Rissa
Posts: 18
Joined: Fri Oct 19, 2007 6:24 am

Re: AtlasQuest 4.5.0 Beta

Post by Rissa » Sat Oct 16, 2010 8:10 pm

unfortunatly i still get error pop ups reports :(

bigmajo
Posts: 4
Joined: Tue Sep 04, 2007 3:52 am

Re: AtlasQuest 4.5.0 Beta

Post by bigmajo » Sun Oct 17, 2010 9:09 am

Date: 2010-10-17 14:53:39
ID: 3
Error occured in: Global
Count: 1
Message: ..\AddOns\AtlasQuest\AtlasQuest.lua line 194:
attempt to index global 'AtlasQuest_Options' (a nil value)
Debug:
[C]: ?
AtlasQuest\AtlasQuest.lua:194: AtlasQuest_SaveData()
AtlasQuest\AtlasQuest_OptionUI.lua:120: AQRIGHTOption_OnClick()
[string "*:OnClick"]:1:
[string "*:OnClick"]:1

Kharthus
Posts: 19
Joined: Mon Jan 15, 2007 10:40 am
Location: Tucson, AZ

Re: AtlasQuest 4.5.0 Beta

Post by Kharthus » Fri Oct 29, 2010 10:38 pm

Saved settings aren't being loaded or saved after logout. Everything in the SavedVariables is from 4.4.3, but nothing new is getting added.

Found the code problems:

AtlasQuest.lua, change line 109 to:
function AtlasQuest_OnEvent(self,event,...)

AtlastQuest.xml, change line 1328 to:
AtlasQuest_OnEvent(self,event,...);

Locked