Atlas Flight Paths issue...

Having trouble installing or using Atlas?
Post Reply
sharkboy007
Posts: 2
Joined: Tue Nov 25, 2008 1:25 am

Atlas Flight Paths issue...

Post by sharkboy007 » Tue Nov 25, 2008 1:31 am

I got an error message (sorry, didn't write it down), and it disable the Flight Path portion of the mod. WoWMatrix shows that all of the modules are 1.13, except for the FlightPaths part, which reads as 1.12. Further, in game, ALL flight paths are now unlabeled, so I have no idea where I'm going, I have to click on one and HOPE I get the right one. This is annoying. Is this now being disabled for this mod, or is it still in progress for updating?

Please let me know, so I know whether to find another mod that will display this information for me. I really don't care to have to memorize every flight path in this game. Great mod, otherwise.

Thanks.

Hegarol
Posts: 524
Joined: Sun Jun 25, 2006 5:48 am
Location: Germany

Re: Atlas Flight Paths issue...

Post by Hegarol » Tue Nov 25, 2008 2:18 am

Delete all folders and reinstall MANUALLY. That should fix it.
Atlasloot Project Lead ; Atlasloot Forum
Image

Daviesh
Posts: 1315
Joined: Sat Jun 03, 2006 5:50 am
Location: Darwin, Australia
Contact:

Re: Atlas Flight Paths issue...

Post by Daviesh » Tue Nov 25, 2008 3:33 am

FlightPaths should not exist, it has been replaced by Transportation.

WoWMatrix is evil in many ways.

User avatar
Dan Gilbert
Developer
Posts: 2579
Joined: Sun Jan 29, 2006 10:24 pm
Location: Amherst, MA
Contact:

Re: Atlas Flight Paths issue...

Post by Dan Gilbert » Tue Nov 25, 2008 4:12 am

When you say "ALL flight paths are now unlabeled" do you mean at an actual flight point or in Atlas? If the former, I'm pretty sure Atlas has nothing to do with the problem.

The Atlas FlightPaths module has simply been replaced with the Transportation module. It's the same thing with a bit of extra information.

sharkboy007
Posts: 2
Joined: Tue Nov 25, 2008 1:25 am

Re: Atlas Flight Paths issue...

Post by sharkboy007 » Tue Nov 25, 2008 3:40 pm

OK, I completely deleted the mod along with any saved variables. Logged in and went to a flight path, only to see...the same thing. No tooltip info comes up when I mouse over a flight path to tell me what that flight path is called. This all occurred after getting a message saying Atlas found an out of date module called Atlas_FlightPath and disabled it. Now, I'm not even seeing a sub folder in there called Atlas_FlightPath. Is there something somewhere I'm not enabling? I've searched the forums and can't seem to find any info regarding this issue.

Thanks.

EDIT: Didn't see this before I posted again:
Dan Gilbert wrote:When you say "ALL flight paths are now unlabeled" do you mean at an actual flight point or in Atlas? If the former, I'm pretty sure Atlas has nothing to do with the problem.

The Atlas FlightPaths module has simply been replaced with the Transportation module. It's the same thing with a bit of extra information.
Before the issue occurred that I just wrote about above, I would be at a flight master and right click. The window would pop up that allows you to click a flight point. Whenever the cursor was placed over that, it would give the name of the flight point (i.e. "Crossroads, Barrens" or "Moa'ki, Dragonflight"). After getting the above error message, there is now no longer any info as to what that flight point is called. I'm currently having to guess as to whether a particular flight point is the correct one or not (and 9 out of 10 times, it isn't, because I don't have the Northrend locations committed to memory yet). Again, the error message that I got prior to this getting disabled specifically said that Atlas had found an out of date module called Atlas_FlightPaths and disabled it. A scan with WoWMatrix showed that all modules for Atlas were at 1.13 EXCEPT Atlas_FlightPaths, which remained at 1.12. As you can see from above, uninstalling everying and installing manually (which is what I do, I only use WoWMatrix to tell me if something is out of date), I now am missing Atlas_FlightPath, which is the module that I believe contained the flight point info.

I know you said it was combined in with the Transportation mod, however, I am as of yet unable to find any setting that will restore the tooltip containing the flight point name to the window you click on to fly.

User avatar
Dan Gilbert
Developer
Posts: 2579
Joined: Sun Jan 29, 2006 10:24 pm
Location: Amherst, MA
Contact:

Re: Atlas Flight Paths issue...

Post by Dan Gilbert » Tue Nov 25, 2008 8:21 pm

I can assure you, Atlas does absolutely nothing that would affect the tooltips at an actual flight master. You've encountered an unfortunate coincidence.

I would suggest deleting (or disabling, or backing up) all of your addons, doing the same with your WTF folder, and seeing if the problem persists.

Please report back.

Ackis
Posts: 7
Joined: Fri Jun 01, 2007 10:17 pm

Re: Atlas Flight Paths issue...

Post by Ackis » Wed Nov 26, 2008 2:09 pm

I believe the Curse Client install had this issue as well when updating.

miwin1000
Posts: 1
Joined: Wed Feb 11, 2009 10:59 am

Re: Atlas Flight Paths issue...

Post by miwin1000 » Wed Feb 11, 2009 11:04 am

I got the error message to delete the file "Atlas_flightpaths 1.12.13". I have not been able to find this file. Where would it be located?

Daviesh
Posts: 1315
Joined: Sat Jun 03, 2006 5:50 am
Location: Darwin, Australia
Contact:

Re: Atlas Flight Paths issue...

Post by Daviesh » Wed Feb 11, 2009 9:49 pm

You will have a folder in your AddOns directory called Atlas Flight Paths (or similar). Get rid of it, as Atlas_Transportation replaces it.

Post Reply