Error pops immediately after logging in

Describe any bugs you've found.
Post Reply
we7simpsons
Posts: 4
Joined: Wed Sep 21, 2011 2:42 pm

Error pops immediately after logging in

Post by we7simpsons » Wed Sep 21, 2011 2:45 pm

Date: 2011-09-21 14:38:57
ID: 1
Error occured in: Global
Count: 4
Message: ..\AddOns\Atlas\Core\Atlas.lua line 222:
bad argument #1 to 'lower' (string expected, got nil)
Debug:
[C]: ?
[C]: lower()
Atlas\Core\Atlas.lua:222:
Atlas\Core\Atlas.lua:221
Atlas\Core\Atlas.lua:243:
Atlas\Core\Atlas.lua:241
[C]: sort()
Atlas\Core\Atlas.lua:269: Atlas_PopulateDropdowns()
Atlas\Core\Atlas.lua:122: Atlas_RegisterPlugin()
...ddOns\Atlas_Entrances\Locale\AtlasEntrances-enUS.lua:281: in main chunk
AddOns:
Swatter, v5.12.5198 (QuirkyKiwi)
WowheadLooter, v40019
Ace3, v
AckisRecipeList, v2.2.8
ACP, v3.3.16
Armory, vv9.8.0
ArmoryGuildBank, vv9.8.0
Atlas, v1.20.1
AtlasBattlegrounds, v1.20.1
AtlasDungeonLocs, v1.20.1
AtlasEntrances, v1.11.0
AtlasLootLoader, vv6.04.04
AtlasQuest, v4.6.6
Skillet, v
BlizRuntimeLib_enUS v4.2.2.40200 <us>
(ck=168)

User avatar
Lothaer
Posts: 652
Joined: Sat Dec 16, 2006 11:07 pm
Location: South Australia

Re: Error pops immediately after logging in

Post by Lothaer » Wed Sep 21, 2011 5:42 pm

i just logged in with the current live version of of Atlas with no issues. can you provide some more details? like where you were what you were doing what version of WoW your using etc.
Image
Titan Team Member.

we7simpsons
Posts: 4
Joined: Wed Sep 21, 2011 2:42 pm

Re: Error pops immediately after logging in

Post by we7simpsons » Sat Sep 24, 2011 7:59 am

It happens with every toon I have. They're mostly parked in Stormwind; but, I've had it happen to a mage I'm leveling and I just leave her wherever I happen to be when I'm tired of playing her. Could by any zone. I'm using version 4.2.2.14545 of Warcraft. My next step is going to be completely wiping all traces of atlas, atlasloot and any addons I use that interact with atlas and then reinstalling and logging in one at a time. When I get around to doing that I'll let you know my results.

we7simpsons
Posts: 4
Joined: Wed Sep 21, 2011 2:42 pm

Re: Error pops immediately after logging in

Post by we7simpsons » Sat Sep 24, 2011 8:00 am

Oh.. and I'm using 1.20.1 of Atlas and 6.04.04 of Atlasloot Enhanced.

we7simpsons
Posts: 4
Joined: Wed Sep 21, 2011 2:42 pm

Re: Error pops immediately after logging in

Post by we7simpsons » Sat Sep 24, 2011 8:53 am

Okay.. must have been a corrupt file somewhere or something else that was mashed up somehow. My first step in my own troubleshooting was to remove all traces of atlas anything from my wow directory. Did this by a simple search for atlas in the root directory and then a ctrl+a, delete on the results. Loaded wow and no error. Then installed a fresh copy of 1.20.1 and login. No error. Then a fresh copy of 6.04.04 and login. No error. I didn't bother to reinstall AtlasQuestFU because I just don't use it anymore. I'll reply to this thread if anything pops up along the way; but, at this time, seems a fresh virgin install corrected the issue.

User avatar
arith
Posts: 910
Joined: Tue Apr 04, 2006 4:42 am
Location: Kalimdor

Re: Error pops immediately after logging in

Post by arith » Sun Sep 25, 2011 9:22 am

Glad to see the problem is resolved now.

Rissa
Posts: 18
Joined: Fri Oct 19, 2007 6:24 am

Re: Error pops immediately after logging in

Post by Rissa » Fri Dec 23, 2011 6:29 pm

speaking of pop-up errors

Date: 2011-12-23 22:11:56
ID: 122
Error occured in: AddOn: AtlasLoot
Count: 64
Message: Note: AddOn AtlasLoot attempted to call a protected function (CompactRaidFrameManagerContainerResizeFrame:Hide()) during combat lockdown.
Debug:
[C]: Hide()
...mpactRaidFrames\Blizzard_CompactRaidFrameManager.lua:560: CompactRaidFrameManager_LockContainer()
...mpactRaidFrames\Blizzard_CompactRaidFrameManager.lua:553: CompactRaidFrameManager_UpdateContainerLockVisibility()
...mpactRaidFrames\Blizzard_CompactRaidFrameManager.lua:47:
...mpactRaidFrames\Blizzard_CompactRaidFrameManager.lua:40

Date: 2011-12-23 22:18:34
ID: 121
Error occured in: AddOn: AtlasLoot
Count: 47
Message: Note: AddOn AtlasLoot attempted to call a protected function (CompactRaidFrame10:SetPoint()) during combat lockdown.
Debug:
[C]: SetPoint()
..\FrameXML\FlowContainer.lua:151: FlowContainer_DoLayout()
..\FrameXML\FlowContainer.lua:17: FlowContainer_ResumeUpdates()
...actRaidFrames\Blizzard_CompactRaidFrameContainer.lua:186: CompactRaidFrameContainer_LayoutFrames()
...actRaidFrames\Blizzard_CompactRaidFrameContainer.lua:131: CompactRaidFrameContainer_TryUpdate()
...actRaidFrames\Blizzard_CompactRaidFrameContainer.lua:58: CompactRaidFrameContainer_OnEvent()
[string "*:OnEvent"]:1:
[string "*:OnEvent"]:1

in fact there are quite a few with only the top 2 lines popping up, which happens in raids, instances and PvP area's thusfar (WG, TB for pvp) do not know about BG's as i do not do those.

User avatar
arith
Posts: 910
Joined: Tue Apr 04, 2006 4:42 am
Location: Kalimdor

Re: Error pops immediately after logging in

Post by arith » Mon Dec 26, 2011 12:34 am

This looks to be AtlasLoot related, not Atlas.

Post Reply