1.12.0 Buggrabber bugs

Describe any bugs you've found.
Post Reply
joshmiller83
Posts: 3
Joined: Mon May 05, 2008 9:54 am

1.12.0 Buggrabber bugs

Post by joshmiller83 » Sat Jul 19, 2008 8:24 pm

"Atlas-1.12.0\\Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)\nAtlas-1.12.0\\Atlas.lua:380: in function <Interface\\AddOns\\Atlas\\Atlas.lua:379>\nAtlas-1.12.0\\Atlas.lua:403: in function <Interface\\AddOns\\Atlas\\Atlas.lua:402>\n<in C code>: in function `sort'\nAtlas-1.12.0\\Atlas.lua:448: in function `Atlas_PopulateDropdowns'\nAtlas-1.12.0\\Atlas.lua:326: in function `Atlas_RegisterPlugin'\nAtlas_OutdoorRaids-1.12.0\\Atlas_OutdoorRaids.lua:135: in main chunk\n\n ---"

"Atlas-1.12.0\\Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)\nAtlas-1.12.0\\Atlas.lua:380: in function <Interface\\AddOns\\Atlas\\Atlas.lua:379>\nAtlas-1.12.0\\Atlas.lua:403: in function <Interface\\AddOns\\Atlas\\Atlas.lua:402>\n<in C code>: in function `sort'\nAtlas-1.12.0\\Atlas.lua:448: in function `Atlas_PopulateDropdowns'\nAtlas-1.12.0\\Atlas.lua:326: in function `Atlas_RegisterPlugin'\nAtlas_FlightPaths-1.12.0\\Atlas_FlightPaths.lua:192: in main chunk\n\n ---"

"Atlas-1.12.0\\Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)\nAtlas-1.12.0\\Atlas.lua:380: in function <Interface\\AddOns\\Atlas\\Atlas.lua:379>\nAtlas-1.12.0\\Atlas.lua:403: in function <Interface\\AddOns\\Atlas\\Atlas.lua:402>\n<in C code>: in function `sort'\nAtlas-1.12.0\\Atlas.lua:448: in function `Atlas_PopulateDropdowns'\nAtlas-1.12.0\\Atlas.lua:326: in function `Atlas_RegisterPlugin'\nAtlas_DungeonLocs-1.12.0\\Atlas_DungeonLocs.lua:127: in main chunk\n\n ---"

"Atlas-1.12.0\\Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)\nAtlas-1.12.0\\Atlas.lua:380: in function <Interface\\AddOns\\Atlas\\Atlas.lua:379>\nAtlas-1.12.0\\Atlas.lua:403: in function <Interface\\AddOns\\Atlas\\Atlas.lua:402>\n<in C code>: in function `sort'\nAtlas-1.12.0\\Atlas.lua:448: in function `Atlas_PopulateDropdowns'\nAtlas-1.12.0\\Atlas.lua:326: in function `Atlas_RegisterPlugin'\nAtlas_Battlegrounds-1.12.0\\Atlas_Battlegrounds.lua:216: in main chunk\n\n ---"

"Atlas-1.12.0\\Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)\nAtlas-1.12.0\\Atlas.lua:380: in function <Interface\\AddOns\\Atlas\\Atlas.lua:379>\nAtlas-1.12.0\\Atlas.lua:403: in function <Interface\\AddOns\\Atlas\\Atlas.lua:402>\n<in C code>: in function `sort'\nAtlas-1.12.0\\Atlas.lua:448: in function `Atlas_PopulateDropdowns'\nAtlas-1.12.0\\Atlas.lua:326: in function `Atlas_RegisterPlugin'\n...ns\\AtlasMajorCities\\Locale\\AtlasMajorCities-enUS.lua:3315: in main chunk:\n\n ---"

User avatar
Dan Gilbert
Developer
Posts: 2579
Joined: Sun Jan 29, 2006 10:24 pm
Location: Amherst, MA
Contact:

Re: 1.12.0 Buggrabber bugs

Post by Dan Gilbert » Sat Jul 19, 2008 9:55 pm

Please try again without AtlasMajorCities or any other addons running. Let me know what happens...

joshmiller83
Posts: 3
Joined: Mon May 05, 2008 9:54 am

Re: 1.12.0 Buggrabber bugs

Post by joshmiller83 » Wed Jul 23, 2008 11:24 am

Dan Gilbert wrote:Please try again without AtlasMajorCities or any other addons running. Let me know what happens...
Worked fine once I disabled Atlas Quest and Atlas major Cities. So one of those is the issue.

Thanks.

Daviesh
Posts: 1315
Joined: Sat Jun 03, 2006 5:50 am
Location: Darwin, Australia
Contact:

Re: 1.12.0 Buggrabber bugs

Post by Daviesh » Wed Jul 23, 2008 6:06 pm

joshmiller83 wrote:
Dan Gilbert wrote:Please try again without AtlasMajorCities or any other addons running. Let me know what happens...
Worked fine once I disabled Atlas Quest and Atlas major Cities. So one of those is the issue.

Thanks.
Atlas Major Cities has not been updated with the new data format. It doesn't have an author at the moment, so no timeline is possible.

User avatar
thandrenn
Posts: 307
Joined: Sun Dec 10, 2006 2:10 am
Location: Pennsylvania, USA

Re: 1.12.0 Buggrabber bugs

Post by thandrenn » Thu Jul 24, 2008 2:55 pm

I've been running AtlasQuest (and AtlasLoot) alongside the newest Atlas SVN version as they come out and haven't had any problems. AtlasQuest only looks for the filename of the map currently being displayed, so the new data format doesn't affect it. I only had to change the file paths for the Instance Entrances.
Image

Mr_FJ
Posts: 1
Joined: Thu Nov 05, 2009 3:14 pm

Re: 1.12.0 Buggrabber bugs

Post by Mr_FJ » Thu Nov 05, 2009 4:37 pm

Date: 2009-11-05 20:11:11
ID: 1
Error occured in: AddOn: Atlas
Count: 1
Message: Error: AddOn Atlas attempted to call a forbidden function (FocusUnit()) from a tainted execution path.
Debug:
[C]: FocusUnit()
..\FrameXML\UnitPopup.lua:1206: func()
..\FrameXML\UIDropDownMenu.lua:563: UIDropDownMenuButton_OnClick()
[string "*:OnClick"]:1:
[string "*:OnClick"]:1
AddOns:
Swatter, v3.1.14 (<%codename%>)
Corpse, v3.2.0.1
Achieved, v0.3
ACP, v3.2.0.23
AdvancedTradeSkillWindow, v
Aieeeeee, v1.0
AllStats, v1.0
Atlas, v1.15.1
AtlasBattlegrounds, v1.15.1
AtlasDungeonLocs, v1.15.1
AtlasOutdoorRaids, v1.15.1
AtlasTransportation, v1.15.1
AtlasLoot, vv5.08.06
AtlasLootWrathoftheLichKing, vv5.08.06
AtlasLootFu, vv5.08.06
AtlasMajorCities, vv1.5a
AtlasQuest, v4.3.6
Babylonian, v5.1.DEV.130
BetterInbox, v
Cartographer, v2.0
CartographerBattlegrounds, v2.0
CartographerCoordinates, v2.0
CartographerGroupColors, v2.0
CartographerGuildPositions, v2.0
CartographerInstanceLoot, v2.0
CartographerInstanceMaps, v2.0
CartographerInstanceNotes, v2.0
CartographerLookNFeel, v2.0
CartographerNotes, v2.0
CartographerQuestInfo, v
CartographerWaypoints, v2.0
CartographerZoneInfo, v2.0
Configator, v5.1.DEV.190
CurseProfiler, v
DBMCore, v
DBMPartyWotLK, v
Flightmap, v
Gatherer, v3.1.14
GathererDBWowhead, v1.0.2009-02-18
MinimapZoom, v1.7
Nauticus, v3.2.0
QuestHelper, v1.2.3
SwindlerPreventer, v3.2
Talented, vv2.4.3-release
TalentedSpecTabs, vv2.4.3-release
TheCollector, v0.6.9
VendorBait, v3.2.0.4
VendorFood, v
BlizRuntimeLib_enUS v3.2.2.30200 <eu>
(ck=4f3)

User avatar
Jeehell
Posts: 40
Joined: Mon Aug 13, 2007 12:50 pm
Location: Montreal, Quebec, Canada

Re: 1.12.0 Buggrabber bugs

Post by Jeehell » Thu Nov 05, 2009 6:34 pm

I don't know if it would solve your problem... but I see that you have AtlasMajorCities version 1.5a. It was updated to 1.5b last month.

Also, I see a very strange add-on "AtlasLootWrathoftheLichKing" version 5.08.06. I'm wondering if you don't have a double copy of AtlasLoot loaded in your addons directory because you already have AtlasLoot version 5.08.06 that includes all that is needed.

Jeehell

Daviesh
Posts: 1315
Joined: Sat Jun 03, 2006 5:50 am
Location: Darwin, Australia
Contact:

Re: 1.12.0 Buggrabber bugs

Post by Daviesh » Thu Nov 05, 2009 9:50 pm

Jeehal, each module of AtlasLoot should appear as a seperate load-on-demand module, there is nothing strange there.

User avatar
Jeehell
Posts: 40
Joined: Mon Aug 13, 2007 12:50 pm
Location: Montreal, Quebec, Canada

Re: 1.12.0 Buggrabber bugs

Post by Jeehell » Thu Nov 05, 2009 10:17 pm

Very sorry, my mistake... I answered that from my workplace and wrote my comment only from memory... I should've waited to be home to answer properly....

Celellach
Posts: 662
Joined: Wed Dec 27, 2006 12:52 pm

Re: 1.12.0 Buggrabber bugs

Post by Celellach » Fri Nov 06, 2009 10:46 pm

And please make new topics and not necro a 1 year + thread (which doesn't even have anything to do with 1.12)

Post Reply